[ZRH] Network issue
Incident Report for zrh
Resolved
This incident has been resolved.
Posted Oct 05, 2017 - 00:54 UTC
Investigating
CloudSigma would like to inform you of a network problem we are currently experiencing in our Zurich Cloud location that may affect some of our customers.

Our System Administrators are working on it and we will update you in a timely manner.
Posted Oct 04, 2017 - 23:27 UTC